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1 Introduction 

 

OT BioLab+ is an acquisition and processing tool developed by OT Bioelettronica. It is 

a freeware software downloadable at www.otbiolab.it in the Download section. 

Tutorials are available at www.otbiolab.it in the Tutorial section. OT BioLab+ allows 

to acquire, review and process bioelectrical signals detected using the OT 

Bioelettronica devices listed below: 

 

EMG-USB2+: surface and intramuscular electromyographic amplifier, up to 256 

channels. Each input can acquire signals with a different acquisition mode. 

QUATTROCENTO: surface and intramuscular electromyographic amplifier, up to 400 

channels. 

 

Using OT BioLab+ it is also possible to review and process any kind of signals stored 

in txt format. 

OT BioLab+ has been designed for .Net Framework 4.0, Windows 10 operating both 

with 64 bit. 

  

http://www.otbioelettronica.it/
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2 OT BioLab+ installation 

 

OT BioLab+ installation procedure requires few minutes and allows to install the 

software and preinstall the drivers for EMG-USB, QUATTRO and DUEPRO. Extract and 

run the OT BioLab+ setup file. The start-up window will appear (see Fig. 2.1), click 

“Next” to continue. 

Now, the license agreement window appears (see Fig. 2.1). Read carefully the license 

condition and click “Next” to continue. 

 

FIG. 2.1. OT BioLab+ license agreement window. 

The next step require to choose which drivers (depending on which device you own) 

(see Fig. 2.2). Again, click “Next” to proceed. 
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Fig. 2.2. OT BioLab+ Custom installation. 

It is possible to create a desktop shortcut (see Fig. 2.3). 

 

Fig. 2.3. Desktop Shortcut. 
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Now the software is ready to be installed (see Fig.2.4). 

 

Fig. 2.4. OT BioLab+ installation window. 
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3 Driver installation 

Drivers installation depends on how many drivers you choose to install. 

3.1 EMG-USB drivers 

The installation of EMG-USB drivers can be completed just clicking Next on Fig 3.1. 

After some seconds drivers will be installed and you will reach Fig 3.2. 

 

 

Fig. 3.1. EMG-USB drivers installation window. 
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Fig. 3.2. EMG-USB drivers installed. 

3.2 DUE PRO drivers 

In order to use Due Pro, some steps are required. These windows open automatically 

during installation. 

1. Install FTDI CDM Drivers 

 

2. Click Next.  

 

3. Accept agreement 
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4. FTDI CDM drivers installed. 

 

5. Install Texas Instrument drivers. Click Next. 
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6. Accept agreement. 

 

7. Install 
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8. Open installation folder. 
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9. Run Setup.exe and click Next 

 

10. Accept the agreement 
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11. Install 

 

12. Texas instrument drivers installed. 
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13. Install Virtual Com port drivers. 

14.  

15. Install 
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16. Open the folder C:\Program Files (x86) 

 

17. Go to C:\Program Files (x86)\STMicroelectronics\Software\Virtual comport 

driver 
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18. Choose the right folder. If you have Windows 10, then choose Windows 8 

folder. 

19. Choose the file depending on your operative system. If your operative system 

is 64 bits, choose dpinst_amd64.exe, otherwise choose dpinst_x86.exe 

 

20. Run it 
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21. Driver installed. 
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4 Main Interface 

 

Running OT BioLab+ you will meet the main interface, shown in Figure 4.1. 

 

 

 

File tool strip drop down list let open, import or save files (Figure 4.2). 

 

 

Subject tool strip drop down list let you manage subject database, adding new subjects 

or editing them. 
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Tool let you edit settings, language and theme of the interface. 

 

 

View let you change positioning of toolbar or see the abstract of the opened file. 

 

 

Acquisition let you control the acquisition process. 

 

 

5 Settings & Privacy 

 

Settings form let you control some accessories parameters, like default saving folder, 

Setup style, Font, Privacy or device settings. 

Privacy let you choose which info you want to share with OT Bioelettronica. Info 

requested are only for statistical reason, in order to improve OT BioLab performance. 

No acquired data will ever be shared with OT Bioelettronica. 

 

6 Acquisition Setup 

In order to setup your acquisition, choose your device and sampling frequency. Then 

fill the form with Adapters, Electrodes and Parameters you want for you acquisition. 

When you finish the setup, click on “Setup complete” to save it. 
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Fig. 6.1. OT BioLab+ Acquisition Setup Editor TreeView. 

 

 

You can choose between TreeView Setup and Grid Setup. In order to choose it, look 

in the Settings form. 

 

7 Signal Acquisition 

 

In order to start an acquisition, click on Acquisition > Start Visualization or click on the 

Play button on the toolbar from the main interface. 

After pressing start visualization, 3 forms are visible: 

1. Main: main interface, where acquired signals are always visible. 

2. Channel List Real Time: a resume list that shows which signals are available 

and where. 
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3. Performances: a chart that keeps the user informed of performances required 

by the acquisition. If it grows too high, there is the risk of acquisition fail and 

data loss. 

 

Fig. 7.1. OT BioLab+ Signal Acquisition Interface. 

 

Clicking on Acquisition > Start Recording, a file start being filled with data acquired. 

Clicking Acquisition > Stop Visualization, acquisition will be stopped without saving. 

Clicking Acquisition > Stop Recording acquisition will be stopped and saving process 

will start. 

When saving, choose the subject that performed the experiment selecting it from the 

subject database and then save it where you prefer. 

At the end of saving process, acquisition will restart automatically. 

 

8 Real Time Processing 

 

One of the most important improvements of OT BioLab+ is the introduction of Real 

Time Processing. They can be called from the Real Time Channel List right clicking on 

the signal of interest and choosing the processing you prefer. 
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8.1 Move Track To... 

This processing let you clone the track on another form in order to have a copy of the 

signal and see it better. 

 

 

8.2 Activation Map 

This processing is available only for matrices 32 or 64 channels and let you see an 

activation map in order to identify the zone that is more active. A real time barycentre 

is shown on it. Colour of the map depends on the amplitude of the ARV of signal 

acquired. 

Refresh epochs are 1Hz, 2Hz or 4Hz. 
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8.3 Activation Map EEG 

Colour of the map depends on the amplitude of the ARV of signal acquired. The refresh 

rate is 1Hz and. 

 

 

8.4 ARV Bar 

This processing shows the bar chart whose value is the amplitude of ARV computed 

on an epoch of 62.5 ms. The refresh rate is 16 Hz. 
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8.5 ARV Chart 

This processing shows a chart with the value of amplitude of ARV computed of an 

epoch of 62.5 ms. The refresh rate is 16 Hz. 

 

 

8.6 Differential 

This processing is available only for matrices 32 or 64 channels. This processing will 

ask confirm about which is the matrix used for recording and will ask the direction of 

differential. Then it will compute the number of groups to plot (depending on matrix 

and direction) and will fill it with the difference between the correct signals. 
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8.7 FFT 

This processing can be applied only to a single signal and shows the FFT over the last 

second acquired. 
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8.8 Trapezoidal Feedback 

Trapezoidal feedback let you perform experiments when you have to follow a path. 

 

 

Though the Settings button you can access to settings of the path. You can record the 

MVC using the start MVC or writing it on your own. A timer is implemented to help 

you performing MVC. 

Clicking on Start Protocol the yellow dot start moving on the screen leaving a blue 

drift, so that it is possibile to see the requested path and the performed path. 

Refresh rate is 16 Hz. 

 

9 Signal Review 

OT BioLab+ allows to open and review different file types. There are two methods to 

load a file: using the Open function under the File menu or from the Menu toolbar, or 

using the Import function under the same menu and toolbar. The Open method simply 

open a new file and, in case other signals are currently opened, they will be closed (if 

they are not saved a prompt will ask the user if the user want to save them). The 

Import method keep the currently opened signals and adds the new ones under them. 
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The Import function can be particularly useful, for example, when signals recorded 

using more μEMG-S devices have to be managed. 

9.1 File extension 

OT BioLab+ can manage different kind of files: 

 otb+: files created by OT BioLab+ containing acquired signals, setup details, 

subject information, processing data and workspace. 

 otb: files created by OT BioLab containing acquired signals, setup details, 

subject information, processing data and workspace. 

 brx: files generated by bruxoff and containing two EMG signals and one ECG 

signal.  

 emg: files generated by μEMG or μEMG-S and containing a single EMG channel. 

 frc: files generated by P-ForceMet and containing a single force channel. 

 bio: files generated by foremg and containing 4 EMG signals. 

 txt: any text file containing data can be opened. To open it, OT BioLab require 

some details regarding the format. For this reason a Text File Information 

window appears asking the user to choose the decimal separator, the columns 

delimiter, the time column or at least the time increment between subsequent 

lines. When all the information are inserted it is possible to open the data.  

All files, once opened, can be processed, manipulated and saved as .otb+ file. 

9.2 Reviewing a signal 

When opening a signal in Review Mode, OT BioLab+ displays a window similar to 

Fig.9.1. The tracks are displayed in the same way as for Visualization Mode and the 

same options to manage the tracks are available during the review (refer to Tracks 

options section). 
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FIG. 9.1. Screenshot during signal review showing an example of signals. 

 

Epochs  

In Review Mode, the signals are segmented in epochs. The epoch size can be defined 

by the user in the Set Epoch field, in the toolbar. The epoch segmentation is necessary 

for several processing plug-in. The signals can be selected in two ways: a left click on 

the Sensor name area selects the entire signals, a drag through the desired epoch 

while pressing the left mouse button selects a group of subsequent epochs. 

 

Edit Toolbar  

When more signals have been detected from a single sensor, they are grouped 

together by creating a multiple track. In Review Mode, it is possible to group and 

ungroup signals as desired.  

To ungroup signals select a multiple tracks and then press the minus green button on 

the Edit toolbar or select Edit ->Ungroup Selected Tracks from the main menu bar. All 

the signals related to the original sensor will be spitted in single tracks and moved 

under the last signal, in the bottom part of the OT BioLab+ Review window. The name 

of single tracks will be assigned automatically by keeping the enumeration of sensor 

channels.  
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To group together two or more signals select the desired signals and then press the 

plus green button on the Edit toolbar or select Edit ->Group Selected Tracks from the 

main menu bar. The new multiple track generated will be moved under the last signal, 

in the bottom part of the OT BioLab+ Review window.  

A given track can be deleted if desired, by selecting the track an pressing the Delete 

red button on the Edit toolbar or selecting Edit ->Delete Selected Tracks from the 

main menu bar. Even if the track and related signals are no longer displayed, in any 

case, the originally acquired data is preserved in the otb+ file. 

 

View Toolbar  

The View toolbar and the View menu include several options for the review of signals. 

The available functions are:  

 Zoom In: increases the time view resolution by reducing the time window 

displayed. This function it is also accessible by using the mouse scroll wheel 

together with the CTRL button.  

 Zoom Out: decreases the time view resolution by enlarging the time window 

displayed. This function is also accessible by using the mouse scroll wheel 

together with the CTRL button.  

 Zoom to Selection: expand the time selection to fit the full screen.  

 Fit in Window: fits the entire signals to the full screen.  

 

Subject Toolbar  

Every signal acquired has to be stored together with subject details. For each subject 

it is possible to create a record containing all the related data. The records are 

collected into a database. OT BioLab give the user the possibility to manage different 

databases. This feature can be useful for privacy aspects when more user use the 

same PC but they don’t want to share the subjects information.  

By default one database is created by OT BioLab during installation in a folder 

managed by the O.S. that the user can’t access directly. If the user do not need more 

than one database no operation are required, automatically the default database is 

used and all the operation are performed on it. Alternatively, under Subjects -> 
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Manage Database it is possible to create a new database or select an existing one. 

The database created by the user can be saved everywhere on the hard drive or 

external memory devices with the desired filename. The extension, by default is .otdb. 

When a user database is selected, OT BioLab keep memory of the database even 

when the software is restarted. In case file .otd is removed, renamed or moved from 

the originally folder, by default the software switch to the default database.  

 

FIG. 9.2. Subject Editor window. It allows to add a new subject to the database or edit the 

information related to an existing subject. 

 

Subjects can be add to the database at the end of a recording, but it is also possible 

to insert new subjects at any time. In particular, it is possible to add new subjects to 

the database or find and edit the subjects record. Pressing the Add New Subject button 

in the Subject toolbar, the Subject Editor window appears (see Fig. 9.2). All the 
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information related to a subject can be typed, few of them are compulsory, and then, 

pressing the OK button, the subject is added to the database. 

In case some information related to one subject has to be modified, it is possible to 

search the subject into the database, and then edit any desired field. The Find/Edit 

Subject button on the Subject toolbar open the search window. Any parameter of a 

subject can be used to find its record into the database. 

 

9.3 Signal export 

It is possible to export the signals acquired using OT BioLab to use them with different 

software (e.g. Matlab, Excel, LabView...). Two are the methods to export the signals: 

“Selected signal(s)” or “Raw data set”.  

Using the option “Selected signal(s)” it is possible to export single or multiple traks, 

the result of a processing or a subgroup of signals acquired. The export can be done 

using different file type: Binary, CSV or Matlab files. Refer to the following paragraph 

for further details.  

The “Raw data set” option allows to export the entire data set related to an acquisition. 

All the signals originally acquired and for the entire acquisition time are exported 

together regardless of any applied selection. The signals are exported in binary format. 

 

Export binary data 

To use this option, during review, choose File->Export->Raw data setfrom the main 

menu bar. The signals exported are saved as a .sig file. All the signals originally 

acquired and for the entire acquisition time are exported together regardless of any 

applied selection. 

The .sig file exportedis a binary file structured as a number of row equal to the number 

of channels acquired (i.e. number of rows occupied by sensors in the setup used 

during the acquisition) and a number of columns that depends on the signals duration. 

The sample values are signed short in the range -2048 ÷ 2047.  

The following formula can be used to obtain the signals amplitude x at the input of 

the amplifier, given each binary value N in the .sig file: 
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𝑥 = 𝑁
𝑉𝐴𝐷 ∙ 1000

2𝐴𝐷𝑅𝐸𝑆 ∙ 𝐺𝑎𝑖𝑛
 [𝑚𝑉]; 

where:  

 ‘VAD’ is theA/D converter input range in volts  

 ‘ADRES’ is the A/D converter resolution  

 ‘Gain’ is the gain used during the acquisition for the corresponding channel  

 ‘1000’ allow to obtain the result in mV.  

For example, when using EMG-USB, EMG-USB2 and MEBA, the A/D converter input 

range (VAD) is 5 V, the resolution (ADRES) is 12 bits and the Gain for each sensor can 

be find in the abstract file. Note that the gain for AUX channels is 0.5 V/V since the 

inputs accept -5 ÷ 5V dynamics, but the A/D converter input range is 0 ÷ 5V. 

 

Export CSV data 

Single channels, subgroups of acquired channels or processing results can be exported 

in CSV (comma separated value) format. To export a .csv file select the desired tracks, 

choose File->Export->Selected signal(s)->As CSV file... from the main menu toolbar. 

An error will occur if track with different sampling frequency are selected to be 

exported together.  

After the filename and the position has been selected the Export Settings window is 

displayed (see Fig. 9.3) where it is possible to select the type of header and decimal 

separator. 

 

FIG. 9.3. Export Settings window. It allows to set the exporting options. 

The data is exported with signals amplitude estimated by OT BioLab representing the 

input signals at the amplifier inputs, taking into account the gain used during the 

acquisition. By default the time columns is added and the measurement units are 

indicated in the file header.  

Note that it is not possible to export simultaneously different tracks if they has been 

acquired with different sample frequencies. 

 

Export Matlab Files 
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Single channels, subgroups of acquired channels or processing results can be exported 

in as a Matlab file. To export a .mat file select the desired tracks, choose File->Export-

>Selected signal(s)->As MAT file... from the main menu toolbar. An error will occur if 

track with different sampling frequency are selected to be exported together.  

The .mat file exported can be open using Matlab. After the file has been open different 

variables will be added to the workspace:  

 Data: an N-by-M matrix containing the exported data, N is the number of 

samples exported, M is the number of channels exported;  

 Description: an M row vector containing the description of each channel 

exported;  

 OTBFile: is the path and filename of the .otb file where the data has been 

exported;  

 SamplingFrequency: is the value in Hz;  

 Time: is an N row vector containing the time instant for each sample of the 

exported data. 

After the file loading the Matlab command plot(Time, Data(:,1)) will produce a graph 

of the first channel exported versus the time. 

 

10 Signal Processing 

OT BioLab allows to process any kind of signals managed by the software itself (refer 

to the File Extension section). The processing tools are available in Review Mode. 

Processing functions are accessible under the Processing menu or with right click on 

channel list.  

There are processing plugins that can be only applied to single tracks and other 

processing can be applied both to a single tracks or to a multiple tracks (refer to Track 

Options section).  

All the processing tools do not change the recorded signals but generate new tracks 

under the last existing track. 
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10.1 Absolute value 

The plugin, when applied, simply rectify the signals. 

 

10.2 Amplitude 

This processing tool use two standard amplitude estimators to generate two new 

single tracks containing the results. The estimators are the Average Rectified Value 

(ARV) and the Root Mean Square (RMS). The two tracks generated are added under 

the last existing track. In both cases a value for every epoch is calculated and displayed 

as a point in the middle of each epoch. When the zoom is set to display more epochs, 

the points are connected each other by displaying a line between each adjacent points.  

The estimation of ARV (AARV) is obtained for the epoch i using the following formula: 

𝐴𝐴𝑅𝑉(𝑖) =
1000

𝑁
∑|𝑥𝐾|

𝑁

𝐾=1

 [𝜇𝑉]; 

Where:  

- ‘N’ is the number of samples per epoch  

- ‘xK’ is the amplitude of the signal at the input of the amplifier in mV. 

- ‘1000’ allows to obtain the result in μV. 

The estimation of RMS (ARMS) is obtained for the epoch i using the following formula: 

𝐴𝑅𝑀𝑆(𝑖) = 1000√
1

𝑁
∑ 𝑥𝐾

2

𝑁

𝐾=1

 [𝜇𝑉]; 

Where:  

- ‘N’ is the number of samples per epoch. 

- ‘xK’ is the amplitude of the signal at the input of the amplifier in mV. 

- ‘1000’ allow to obtain the result in μV. 

 

10.3 Band Pass EEG 

This processing will extract from one signal 5 signals whit 5 eeg bands (see Fig 

10.1). 
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FIG. 10.1. Band Pass EEG parameters. 

 

10.4 Calibration 

This processing plugin can be used to calibrate a signal acquired for example using a 

load cell to obtain the trace directly expressed in the correct measurement unit and 

with the correct scale. Morover it is possible to remove an offset to obtain the correct 

zero level. 

 

10.5 Convolution 

This processing performs convolution between two signals in order to recognize the 

highest cross correlation between them. Once it recognize it, it will shift in time the 

second signal in order to align them. 

 

10.6 Conduction velocity estimation 

This tool has been designed for the estimation of conduction velocity (CV) from single 

differential signals detected by an electrode array. It is possible to use three different 

plug-ins to estimate the CV.  

The first plug-in that appears in the dropdown menu under “CV Estimation” is named 

“Conduction velocity Phase Delay (3 signals)” and it requires three single differential 
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signals to estimate a CV value. The three signals must be three single tracks selected 

by the user. The tracks can be grouped or ungrouped. In case the user needs to use 

the “free selection” on tracks it is recommended to group tracks to optimize the 

selection.  

The algorithm calculates two double differential signals from the three single 

differential signals and then estimates the delay between the two signals obtained in 

a least square sense in the frequency domain. For further details on the delay 

estimation refer to:  

 

McGill K.C., Dorfman L.J. High-resolution alignment of sampled waveforms. IEEE Trans 

Biomed Eng, BME-31: 462–468, 1984  

 

Once the delay is estimated, CV is obtained dividing the distance between electrodes 

by the delay obtained. The indication of the Inter Electrodic Distance (IED) is first of 

all searched in the sensor name field of the signals, in case it is not found it is asked 

to the user.  

The track containing the results is added under the last existing track. A value for 

every epoch is calculated and displayed as a point in the middle of each epochs. When 

the zoom is set to display more epochs, the points are connected each other by 

displaying a line between each adjacent points.  

The second plug-in that it is implemented is based on a different algorithm and is 

named “Multichannel Conduction Velocity”. With this plug-in it is possible to select and 

use different channels (three or more) to estimate the CV. Also in this case the tracks 

can be groped or ungrouped. In case the user needs to use the “free selection” on 

tracks it is recommended to group tracks to optimize the selection (see Fig.10.2). 
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FIG. 10.2. Multichannel CV plugin used on grouped signals. 

 

This multichannel algorithm estimates the CV in the frequency domain. The algorithm 

is described in the paper:  

 

“Assessment of average muscle fiber conduction velocity from surface EMG signals 

during fatiguing dynamic contractions.” D.Farina et al, IEEE Trans Biomed Eng. 2004 

Aug;51(8):1383-93 

 

and it provides an estimation of the CV from a set of EMG signals in a time interval in 

which the mean square error (mse) between aligned signals is minimized. The 

minimization of the mse function is performed in the frequency domain, without 

limitation in the time resolution and with an iterative computationally efficient 

procedure. The algorithm that is implemented in OT Biolab uses a rectangular window 

with an amplitude of unity. This choice was adopted in order to minimize the 

computational time of the algorithm. The CV is calculated for epochs as for the 

previous algorithm. The track containing the results is added under the last existing 

track. The value for every epoch is displayed as a point in the middle of each epoch.  

The third plug-in is named “Windowed conduction velocity” and it allows to calculate 

the CV at the center of a free selection. The signal is windowed in time domain by a 

Gaussian function. The algorithm used is the same of the Multichannel CV, so three 

or more signals can be selected. In this case it is necessary to group the tracks in 

which the user calculates the CV. Using the free selection the plug-in calculates the 

CV at the center of the selected time interval as reported in Fig. 10.4. When this plug-
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in is selected a window will appear to select the desired sigma in milliseconds of the 

Gaussian window. The calculated value is reported in a new track at the center of the 

selected interval (see Fig. 10.4). 

 

FIG. 10.4. Example of a windowed CV calculated with a Gaussian function (sigma of 30 ms). 

 

10.7 Data approximation 

OT BioLab can provide different type of data approximation. In particular, three 

different tools are grouped under the Data Approximation menu voice: average, linear 

and parabolic.  

The three approximations can be applied at any kind of single track but they are 

intended to be applied on processing results based on epochs: amplitude, frequency 

or conduction velocity estimation results.  

When running a data approximation on a track, the software calculates the polynomial 

curve with the desired grade best fitting the data set, minimizing the square error. 

The polynomial curve obtained is superimposed to the track containing the data set 

and drown in red. The identified coefficients are indicated in the sensor name. 

 

10.8 Decomposition > Decomponi 

The plugin, when applied, decompose the grouped signals. In Settings form you can 

set parameters of decomposition algorithm. The result is a grouped signals with a 

spike when the motor unit fires. 



OT BioLab+  User Manual v.1.0 

40 

 

 

 

 

 

FIG. 10.5. Decomponi parameter setting. 

 

10.9 Decomposition > Extract Motor Units 

This plugin shows the template of the decomposed motor units.  

In order to use this plugin, proceed as follows:  

1. Select signals and decomposition.  

2. Run Decomposition > Extract Motor Units  
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FIG. 10.6. Motor Unit extraction result. 

 

10.10 Decomposition > Mean firing rate 

This plugin can be applied to decomposed signals. This plugin draws a curve showing 

the firing rate of motor units during acquisition. 

 

10.11 Derivative 

Performs derivative of a signal. 

 

10.12 Envelope 

Extract the envelope from a single track and normalize it with respect to the envelope 

maximum peak. The tool has been designed for EMG signals, the resulting signal is 

obtained by rectifying the desired signal and applying a II order Butterworth low pass 

filter with 5 Hz corner frequency to the rectified signal. 
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10.13 FFT 

The FFT can be estimated from single tracks on the desired number of epochs. After 

selecting the track a window will appear (Fig. 10.7) for selecting the number of 

samples that will be used to obtain an averaged FFT to reduce the noise in the 

estimated power spectrum. A minimum of 256 samples for the averaged FFT is 

required. The maximum number of samples is equal to the length of the data. From 

this menu the user can select the window functions to apply to the time domain data 

for estimating the FFT (rectangular, hanning, hamming, blackman). Samples used to 

obtain the averaged FFT can be overlapped (50 % of overlap - Welch’s method) or no 

overlapped (Barlett’s method) selecting the options that appears on the bottom-right 

of the window menu. After selecting these options a new window will display the result 

of the algorithm (Fig. 10.8). Details about the FFT algorithm can be found at 

http://sourceforge.net/projects/kissfft. After the FFT has been estimated, keeping the 

left mouse button pressed a rectangular window can be drawn to indicate the area 

that the user want to zoom in. When a right click on the FFT zoom out will be 

performed. 

 

FIG. 10.7. window menu for selecting number of samples. 
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FIG. 10.8. FFT spectrum obtained averaging 1024 samples is shown. 

 

10.14 Filtering 

This processing tool can be applied both to single tracks and multiple tracks. When 

running it, a request of filter type and corner frequencies is displayed. It is possible to 

choose between different type of filters:  

- Low pass  

- Band pass  

- High pass  

- Stop band  

 

Moreover, the corner frequencies are differently asked depending on the filter type 

selected.  

The signals generated by the filtering process are added as single or multiple track in 

the review window leaving unaltered the starting signals.  

All filter types are II order Butterworth filters. 
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10.15 Frequency 

This processing tool uses two standard frequency estimators to generate two new 

single tracks containing the results. The estimators are the Mean Frequency (MNF) 

and Median Frequency (MDF). The two tracks generated are added under the last 

existing track. In both cases a value for every epoch is calculated and displayed as a 

point in the middle of each epochs. When the zoom is set to display more epochs, the 

points are connected each other by displaying a line between each adjacent points.  

The estimation of MNF (fMNF) is obtained for the epoch i using the following formula: 

𝑓𝑀𝑁𝐹(𝑖) =
∑ 𝐼𝑘 ∙ 𝑓𝑘

𝑛
𝑘=0

∑ 𝐼𝑘
𝑛
𝑘=0 

 [𝐻𝑧]; 

Where:  

- ‘n’ is the number of frequency bins in the spectrum  

- ‘fk’ is the frequency of spectrum at bin k of n  

- Ik is the Intensity of spectrum at bin k of n 

The estimation of MDF (fMDF) is obtained bycomparing the total signal spectrum 

intensity divided by two with the cumulative intensity (i.e. all the intensity values for 

frequencies lower and including the focal intensity). The lowest frequency retrieving 

the cumulative intensity bigger than the half total intensity is fMDF. 

 

10.16 Activation Map 

Maps plugin allows show in a 2D plot the matrix signals of 64 electrodes or 32 

electrodes with different colour scales. 

The maps plugin has been designed to process data acquired as MONOPOLAR signals. 

After selecting the matrix type a new window will appear with the visualization of the 

colour map. On the left side of this window, different options are available in order to 

change the visualization of the map depending on the type of analysis that is chosen 

(see Fig. 10.9). 
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Fig. 10.9. Visualization of the colour map and of the menu with different options that can be modified 

 

From the menu map different mode of visualization can be selected: Monopolar, 

Horizontal differential and Vertical differential. With the Monopolar mode, the plot is 

generated from the original signals without additional processing. The Horizontal 

differential mode allows to perform the difference between contiguous electrodes of 

the monopolar signals from left to right of the matrix rows. The Vertical differential 

allows to perform the difference between contiguous electrodes of the monopolar 

signals from top to bottom columns of the matrix.  

The maps can be displayed with two different options: ARV or RAW data.  

Choosing the ARV option, the software estimate, for each signal, the average squared 

values over the epoch selected in the OT BioLab main window (e.g. 0.5 s in Fig. 10.9). 

A cursor bar in the top of the visualization window can be moved to select the colour 

map at a certain time. A “Play” button in the left side of this bar can be used to start 

an automatic display of the maps during the acquisition time or to stop it. 

In the RAW option, the instant values over the acquisition time are used to generate each 

map. With this option it is possible to display the acquired data by showing the 

propagation of the action potential along the muscle fibers.  
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Three different colour bars are available: “Jet”, from blue to red, “Heat”, from black-red-

white and “Bone”, a modified grey scale with a blue colour.  

Four different rotation angle can be chosen: 0, 90, 180 and 270 degrees with respect to 

the orientation that is reported in the left-bottom side with a picture of the selected matrix.  

The minimum and the maximum value of the colour range is reported in μV and can be 

changed in the menu. These values are also updated and reported in the right side of the 

colour bar.  

The minimum and the maximum value can be changed only when the check box of the 

autorange is un-checked.  

 

10.17 Max Min and Mean 

This processing computes max, min and mean value of the selected signal. 

 

10.18 PSD 

The power spectral density (PSD) can be estimated from single or multiple tracks on 

the desired number of epochs. As in the FFT plugin, after selecting the track a window 

will appear for selecting the number of samples that will be used to obtain an averaged 

FFT to reduce the noise (see FFT plugin for details), the window functions and the 

method (Welch or Barlett’ method). After selecting options of this menu two plots will 

show the PSD of the signal in two different units: dB/Hz and mV2/Hz. As an example 

in Fig. 10.10 a PSD signal is shown in logarithmic scale. 
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Fig. 10.10. Example of a PSD spectrum obtained averaging 1024 samples of an EMG channel, the 

plot is reported in logarithmic scale. 

 

10.19 Quality controller buffer/ramp 

This two plugins can be applied only on signals acquired with devices that provide 

ramp or buffer. They show the ramp or the buffer recorded during acquisition. 

 

10.20 Sum 

This processing tool can be applied to a multiple track or to, at least, a pair of single 

tracks. Simply it calculates, sample by sample, the sum between signals.  

When applied to a multiple track it calculates the sum between all channels associated 

to the sensor selected and retrieve a new single track containing the sum.  

Typical application is the use with signals from an electrode array; the processing 

calculates the signals virtually obtained with multiple inter-electrodic distance. 
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10.21 Time shift 

This processing will shift the signal in time. When you run this processing, it will ask 

you how many samples you want to shift the signal. If the number is negative, it will 

move the beginning of the signal forward in time, delaying it. If it will be positive, it 

will remove the first part of the signal. 

 

11 Matlab codes 

In the installer there are some examples file for Matlab coding. They are available 

under the path C:\Program Files\OT BioLab+\MatlabCodes. 

This folder is protected by Windows, then you will have to copy files under another 

path in order to edit them. 

 

12 OTComm 

All the communication is managed by the library OTComm.dll. It is possible to use it 

also without using OT BioLab+. 

Some examples are available under Matlab codes. 

Documentation for OTComm.dll is available in C:\Program Files\OT 

BioLab+\Documentation. 

In order to use OTComm, you just need to import OTComm.dll in your project. It is 

available in the folder C:\Program Files\OT BioLab+. 

 

13 PC Requirements 

Operative system: Windows 10  

Processor: Intel i3 2nd generation.  

Port: USB2.0 and Ethernet 

Hard Disk: 500 MBytes for software installation  

Minimum RAM: 2 GBytes  
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The minimal PC requirements listed allows the proper acquisition of all 256 channels 

of EMG-USB2 equipment (with max sampling frequency 10.240Hz) and a visualization 

of 16 channels simultaneously. The increaseof the number of visualized channels can 

produce a visualization latency or an intermittent visualization. 

 

14 Problem solving 

A problem for the visualization of sensors in the Setup Editor can occur in case the old 

version of the software has not been disinstalled before the installation of the new 

software.  

 

15 OT BioLab Light 

OT BioLab Light has been developed in order to let the user acquire using directly 

from a socket without visualizing data in OT BioLab+. 

Using OT Biolab Light, you can just configure roughly the acquisition and start it. Then 

you will be able to connect using another software that will read the data coming from 

a socket. Data can be read also from another computer available in the same network. 

OT BioLab Light can be used with this devices: 

 EMG-USB2+ 

 QUATTROCENTO 

OT BioLab Light creates a socket on the localhost on the port 31000. 

Interface is shown in Figure 15.1. 

If you want to use Quattrocento, you have to set parameters. Clicking on Edit the 

Figure 15.2 will appear. 

You can set the refresh frequency on the main interface. Refresh frequency is the 

frequency of data available on the socket for the reading. 

In order to see data, you just need to open the socket and send the start command. 

When you open the socket, you will receive 8 bytes. They are “OTBioLab” written in 

ASCII code. 
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Fig. 15.1. OT BioLab Light interface. 

 

Fig. 15.1. OT BioLab Light interface. 
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Detailed command and answers are: 

 startTX: this command starts the communication with the socket. 

 stopTX: this command stops the communication with the socket. 

Data are provided as short in little endian. 

An example of communication is shown in the Matlab Codes folder. 


